開発環境を準備する

GS2 のプロジェクトと Unity のシーンを用意し、接続に使う設定を確認します。

GS2 の学習用プロジェクトと、Unity の空のシーンを用意しましょう。ここで作る GS2 のアカウントは、ゲームの設定を管理する開発者用です。

1. GS2 に登録する

GS2 のサイト(別タブ)から開発者アカウントを登録します。届いたメールのリンクでメールアドレスを確認したら、マネージメントコンソール(別タブ)にログインしてください。

2. 学習用プロジェクトを作る

  1. Project → プロジェクトリスト → プロジェクトを新規作成を開きます。
  2. プロジェクト名に adventure、説明に「冒険ゲームの練習」と入力します。
  3. 最初に有効化するリージョンを 東京 にします。この教材のコードも東京(ap-northeast-1)へ接続します。
  4. 契約プランなどの内容を確認し、作成を押します。

プロジェクト作成画面。左上で名前、左側で最初のリージョンを指定する

プロジェクト名には英数字、ハイフン、アンダースコアを使います。すでに学習用プロジェクトがある場合は、東京リージョンが有効であることを確認して使えます。

3. Unity に設定する接続情報を確認する

作成したプロジェクトの東京リージョンで、Deploy → スタックリスト → Default → アウトプットリストを開きます。次の二つの値を、Unity の接続設定に使います。

アウトプット名Unity で設定する項目
ApplicationClientIdClient ID
ApplicationClientSecretClient Secret

4. Unity とツールを準備する

Unity で空のプロジェクトを作り、シーンを Adventure という名前で保存します。

Studio は、画面で機能を選び、表に設定を入力する方法です。SDK(Unity) は、GS2 の設定と C# コードを自分で書く方法です。下のタブを選ぶと、その方法での準備手順が表示されます。

  1. GS2 Studio のダウンロードページ(別タブ)からデスクトップアプリを導入します。
  2. 起動画面の新規プロジェクトを作成から Adventure を作り、保存先のフォルダーを選びます。こちらはパソコン上の設計データを置くプロジェクトです。
  3. 右上でシンプルを選びます。左側にホーム・機能を追加・表・反映が表示されます。

作成した直後の Adventure。左側に「ホーム・機能を追加・表・反映」が並ぶ

  1. GS2 SDK for Unity インストーラーをダウンロードします。
  2. Unity の Assets → Import Package → Custom Package… からダウンロードしたファイルを選び、Import を押します。
  3. Window → Game Server Services → SDK Installer を開き、Install を押します。
  4. Window → Package Manager で GS2 C# SDK と GS2 SDK for Unity が追加されていることを確認します。

Unity の SDK Installer。Install から SDK を導入する

UniTask を導入する

この教材の SDK コードは UniTask の async / await で書きます。

  1. Window → Package Managerで、導入済みの一覧から UniTask を検索します。
  2. 未導入の場合は + → Install package from git URL… を開き、次のURLを入力して Install を押します。
https://github.com/Cysharp/UniTask.git?path=src/UniTask/Assets/Plugins/UniTask#2.5.11

インポートが完了すると、SDK の LoginAsync() や ModelAsync() を使えます。

次へ:アカウントを作成してログインする